f

Dieses Blog durchsuchen

Wird geladen...

Samstag, 2. Februar 2013

Downgrade Centro Grande

Downgrade von Firmware 6.x auf 5.x

Swisscom hat auf ihre Centro Grande ADB/Pirelli Router bereits grösstenteils die neue Firmware der 6er Generation ausgerollt (6.02.02).
Neben einer besseren Stabilität, wurde in diese Firmware auch eine IPv6 Firewall integriert.
Grundsätzlich gäbe es also keinen Grund sich ein Downgrade zu wünschen.

Die Funktionen über das Web User Interface der Swisscom Router ist traditionell eingeschränkt.
Services wie IPTV und VoIP zwingen den Provider Voreinstellungen auf ihren CPE's zu tätigen.
Eingebürgert hat sich die Konfigurationbeschränkung durch den Kunden, mit der Begründung, dass Kundenkonfigurationen die bereitgestellten Services behindern oder unbrauchbar machen können.
Unlängst sind solche Provider Restriktionen in Deutschland zum Thema geworden, Schlagwort: "Routerzwang".

Somit bringt die 6er Generation der Firmware nicht nur Verbesserungen, sondern teils auch Ärger mit sich.
Das gute alte "Admin Gui" wurde gestrichen. Somit können die Kunden nicht mehr von den vielfältigen Konfigurationsmöglichkeiten von openrg profitieren. Den Reaktionen nach, waren das mehr Kunden als ich dachte.
Bis auf weiteres bleibt somit nichts anderes übrig als ein Downgrade zu starten.

Nun gut. Dies soll kein Blog Post über Sinn oder Unsinn solcher Sachen sein. Hier beschreibe ich nur den Downgrade auf die ältere Firmware. Des weiteren lehne ich jegliche Haftung ab falls es zu Schäden am Router kommt oder in Folge des Downgrades nicht alle Services wie gewohnt funktionieren.


Downgrade durch Image Dateien

Wie manch einer der ein Downgrade machen wollte gemerkt hat, funktioniert es nicht, wenn man einfach eine ältere rmt Datei hochlädt. Der Router bleibt stur auf der 6er Version.
Der Router verfügt aber über einen "Recovery Modus" bei dem man Image Dateien hochladen kann.
Diese Images beinhalten die Firmware ohne Signatur. Ich habe die Signatur der aktuellsten 5er Firmware entfernt und stelle das Image als Download zur Verfügung.

How-to

  1. Lade dir die Vx226N1_50037_04b20.img herunter.
  2. Lade dir die Recovery Firmware Vx226N1_50037R.rmt herunter.
  3. Entferne das DSL Kabel zum Router.
  4. Gibt dem PC welcher die Datei uploaden soll die fixe IP 192.168.1.2/24
  5. Verbinde nur den Upload PC mit dem Router über LAN
  6. Schalte den Router über den seitlichen on/off Knopf aus.
  7. Drücke mit einen Stift sanft auf den versenkten Resetknopf und halte ihn gedrückt.
  8. Schalte den Router ein während der Resetknopf immer noch gedrückt bleibt.
  9. Nach spätestens 10s sollte die Betriebsanzeige an der Front rot leuchten. Man kann nun den Resetknopf loslassen. Bild 1
  10. Mittels Browser kann man nun http:/192.168.1.1 öffnen. Es öffnet sich eine Seite bei der man die Image Datei hochladen kann.  (Vx226N1_50037_04b20.img)  Bild 2
  11. Nach erfolgreichem Upload warten bis der Router wieder zur Verfügung steht. Dies kann mehrere Minuten dauern. In der Anfangsphase ist nicht zu erkennen ob sich was tut. Die BetriebsLED bleibt weiterhin rot. Auf gar keinen Fall darf man den Router in dieser Phase ausschalten!
  12. Nachdem der Router wieder hochgefahren ist (mit der Firmware 5.0.0.37_04b20) lädt man via WUI (Router Firmware aktualisieren) die alte Recovery Firmware hoch. (Vx226N1_50037R.rmt)
    Falls der Zugriff mit den persönlichen Zugangsdaten nicht funktioniert, Router reseten (Resetknopf 30s gedrückt halten) und Benutzername admin, Passwort 1234 verwenden.
  13. Der Router macht nach diesem Schritt einen automatischen Reboot. Danach den Router nochmals richtig reseten. (Resetknopf für ca 30s gedrückt halten) 
  14. Nach erfolgreichem Downgrade ist cwmp (TR-069) zu deaktivieren. Dies sollte vor dem Einstecken des DSL Uplinks geschehen.
Bild 1 Router in Recovery Mode







Bild 2 Image Upload












Kommentare:

user01 hat gesagt…

In den Recovermodus komme ich, upload der firmware Ok.Nach ca. 2-3 min. wechselt die Website des Routers auf http://192.168.1.1/upload.cgi
diese kann nicht Angezeigt werden.
http://192.168.1.1 funktioniert(Bild 2 beschreibung).
Router macht kein reboot.
Aus- und Einschalten Router alte Firmware wieder da. Ideen ???
Router wird am Glasfaseranschluss
betrieben.

Tux0ne hat gesagt…

Hi

Ich habe dieses Verfahren mehrmals mit 2 verschiedenen Geräten getestet und hatte immer Erfolg.

Ich empfehle dir zuerst einen langen Reset des Routers zu machen bevor du mit der Flasherei beginnst. Es mit einem anderen Browser zu versuchen, wie in der Community vorgeschlagen, ist ebenfalls eine gute Idee.

Des weiteren habe ich die Anleitung noch angepasst und einen zusätzlichen Schritt mit einer Recovery Firmware eingefügt. Dies sollte den Router endgültig in den alten Zustand bringen.

TonyH hat gesagt…

Danke viel mals fuer den tip! aber wie kann ich den cwmp (TR-069) deaktivieren?

Danke

Tux0ne hat gesagt…

Hoi Tony

Am einfachsten deaktivierst du dies im Admin GUI unter Fernverwaltung. Dort kannst du die Punkte TR-069 und TR-064 deaktivieren.

Lukas Dittli hat gesagt…

Habe das Problem das das Passwort nicht mehr stimmt bzw. komme nicht mehr in die Konfiguration des Routers rein.

Klaus hat gesagt…

Hallo, leider funktioniert dies nicht mehr bei Version 6.02.12. Beim Image aufspielen bekomme ich immer einen Hinweis "illegale Software". Gibt es diesbezüglich schon Lösungen oder vielleicht noch einen anderen Weg für das Web-Gui. Danke

Tux0ne hat gesagt…

Sali Klaus
Das funktioniert bei mir schon noch.
1. Hast du versuch die img Datei nochmals von Dropbox herunterzuladen.
2. Hast du es mal mit der img Version vom ftb versucht? ftp://ftp.tuxone.ch/Pirelli/Gen6/Vx226N1_50037_04b20.img
3. Oder mit einer eigenen img Version: http://tpirelli.blogspot.ch/2011/02/konvertierung-rmt-zu-img.html?utm_source=BP_recent

Klaus hat gesagt…

Sali TuxOne
Danke für die schnelle Antwort.
1 & 2 habe ich bereits probiert, hat nicht funktioniert.
3 werde ich morgen probieren, schaffe ich heute leider nicht mehr. Gebe dann Bescheid ob es funktioniert hat.

Tobias hat gesagt…

Bei mir funktioniert der FW-Downgrade von Version 6.0.2.12 auf 5.x ebenfalls nicht mehr. Auch mit einem eigenen img file kommt immer noch die Meldung "illegal software".

Rene hat gesagt…

Ist bei mir auch so. Wäre für einen weiteren tip sehr dankbar.

Tux0ne hat gesagt…

Ich suche nach einem Anhalt euer Problem einzukreisen. Ich kann das bei 2 Versionen des Routers welche ich zu Hause habe nicht reproduzieren.

Pascal Bosshart hat gesagt…

Hallo TuxOne,
ich beschäftige mich mit dem selben Problem. Beim Upload erscheint die folgende Meldung:
Image uploading failed. The selected file contains an illegal image
Habe auch mit dem File vom ftp versucht.
Den upload mache ich mit firefox

Unknown hat gesagt…
Dieser Kommentar wurde vom Autor entfernt.
Kagemaru hat gesagt…

Ich konnte das erste Image aufspielen, beim 2ten update auf 50037R ging dann nix mehr. über die Web-Oberfläche hat er mir ein update nur vorgegaukelt, aber es war immer noch die 04b20 drauf.

Über den Recovery Modus (10 Sec Reset beim booten) erscheint bei mir dieselbe Fehlermeldung:

"Image uploading failed. The selected file contains an illegal image"

user01 hat gesagt…

Die Meldung "illegal Software" taucht auf wenn man das Image direkt in der WUI über Router Image Aktualisieren lädt.
1. Schritt Resetknopf min 30 sec drücken bis Powerlampe von ROT auf WEISS blinkt wechselt und dann wieder ROT leuchtet. Fortfahren siehe Punkt 10

Gruss User01

blendenwerk hat gesagt…

Bin ebenfalls am verzweifeln. Der Tipp von user01 führt zur selben Meldung. Gibts hier evtl. eine Lösung?

user01 hat gesagt…

Es gibt ein Problem mit der neueren Routergeneration z.B. :LOT:I-07/14 Date:10/02/14.
Vielleicht hilft es erst auf die Version 6.12 downzugraden, dann auf die 50037.04B20.

Gruss User01

blendenwerk hat gesagt…

Danke user01

Das hatte ich zwischenzeitlich auch schon getestet. Leider kein Erfolg, nicht mal von der 6.02.02 aus. Habe jetzt schon ein paar Stunden 'verbraten'... :-(.

TheFrenchMatt hat gesagt…

Ich auch, downgrade gehts am gui 6.02.02 (auch recovery Firmware) aber upload gehts immer zu illegal (auch mit Konvertierung von Firmware Recovery zu img)

DeeJay CluOcaL hat gesagt…

Hallo
habe das selbe Problem, Fehlermeldung:
Image uploading failed. The selected file contains an illegal image
Die .img sei beschädigt.
Habe bis jetzt auch schon ziemlich alles ausprobiert.

Tux0ne hat gesagt…

Ich habe im Geschäft einen Router mit aktueller Firmware rumliegen. Ich schau mir die Sache mal an. Vermutlich werde ich mal die alte Firmware mit der neuen Signatur kreuzen und mal gucken was Sache ist.

Daniel Etter hat gesagt…

Hallo Tux0ne

Gibt es schon ein Update?
Stehe vor dem gleichen Problem

Gruss
Dani

Peter hat gesagt…

Ähm,und wie komme ich in dieses Admin GUI???

BTW: Nach dem flashen des Vx226N1_50037R.rmt über das WUI, zeigt er immernoch als Version 5.0.0.37_04b20 an. Ist das korrekt so???

Peter hat gesagt…

OK, hab's jetzt rausgefunden wie man dieses Gui aktiviert:
http://supportcommunity.swisscom.ch/t5/Swisscom-Services-Products/Centro-Garnde-A-quick-step-by-step-to-get-advanced-Gui-so-you/td-p/33009

Aber trivial ist das nicht. Da sollte man schon zumindest erwähnen, dass man da zuvor noch 'ne Telnet-Session zum Einrichten braucht und dann einen spezielle URL aufrufen muss...

Aber jetzt funkt es.
Also Vielen Dank für's Tutorial!!!

Chrigi hat gesagt…

Guten Tag, ich habe ein Centro Grande, vermutlich ein Pirelli. Die Firmware ist 6.12.02. Ist es möglich mit dieser Version ein Downgrade durchzuführen? Ich möchte die SIP Daten auslesen. Besten Dank

Gruss Chrigi

Wizzard Ouz hat gesagt…

Habe dasselbe Problem, mit der ungültigen und defekten Imagedatei.

Habe 2 Centrogrande Pirelli rumliegen.
Einer mit LOT I-24/13 kann nicht downgradet werden. Akzeptiert Imagedatei nicht.
Einer mit LOT I-50/12 der kann downgradet werden.

Ist da wer mal weiter gekommen?

Habe einen FTTH Anschluss der mit einer kleinen Box vom Provider auf Kupfer-Ethernet gebracht wird. Habe beim einen Centro Grande den ETH0 Port so konfiguriert, dass er den DHCP des Providers greift (Ethernet dhcp) und konnte so sogar mein Analogtelefon in Line 1 reinstöpseln und alles läuft wunderbar. Internet und voip über sipcall. Der gelieferten gratis Zyxel darf jetzt universal Router sein und das WLAN repeaten :)
Jetzt möchte ich auf dem anderen LOT I-24/12 eben das openwrt installieren und mal schauen was da so alles machbar ist ...

----
Netzwerkverbindung:
- lanbride>briding ETH0 aus der LAN Bridge entfernen (uncheck)
- WAN und alles mit DSL deaktivieren
- eth0>einstellungen ETH0 (ist Anschluss 4) als WAN einstellen und ethernet mit dhcp (automatisch) eth0>routing alle 3 boxen check etho>erweitert firewall check
- RJ41 Kabel von Buchse ET4 nach FTTH/Ethernet Konverterbox einstöpslen

allenfals noch in Schnelleinrichtung kontrollieren ob auf Ethernet automatisch (dhcp) gestellt ist
----

Bei VOIP muss die Kennung zweimal eingegeben werden ...

Leitungsnummer: 1
Benutzerbezeichner:
und
Benutzername für die Authentifizierung:
---

Da bin ich drüber gestolpert ...

gruss

Natalie hat gesagt…

Hallo,

Ist diese Firmware mit dem V226N1W Router kompatibel?

Ausserdem würde ich gerne wissen ob ich damit dann meine W-LAN Einstellungen (SSID, 802.11 Modus, Passwort, etc.) ohne das Kundencenter, sondern direkt am Gerät vornehmen kann.

Grund dafür ist dass ich nun einen Centro Grande Router übrig habe und den gerne als AP nutzen würde. Nur leider kann ich ohne das Kundencenter keine Einstellungen selber vornehmen und wäre somit an einem downgrade bzw. einer alternativen Firmware interessiert.

Vielen Dank!